Installing Ruby and Ruby on Rails

From Projects Wiki
Revision as of 02:16, 19 July 2013 by Ralph Iden (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Installing Ruby and Ruby on Rails

Submitted by Ed Schoolcraft

#installing Ruby on Rails on Raspberry Pi:

#NOTE: Read a note somewhere that you need to use an SD card greater than 4G for this...


sudo apt-get update
#sudo apt-get upgrade (if desired but may take a while if you are way out of date)

sudo apt-get install -y openssl libreadline6-dev git-core zlib1g libssl-dev libyaml-dev libsqlite3-dev sqlite3 libxml2-dev  \
  libxslt-dev autoconf automake libtool bison libgdbm-dev libncurses5-dev libffi-dev

curl -L https://get.rvm.io | bash -s stable --rails

source ~/.rvm/scripts/rvm

#install a javascript runtime
sudo apt-get install nodejs

echo "If the versions do not list properly below, you may need to reboot."
ruby -v
rails -v